#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:<ParagraphB>|\G<\/value>)\s*?<value>([^<]*)"
Local $sString = "<ParagraphA>" & @CRLF & _
"<value>12</value>" & @CRLF & _
"<value>5</value>" & @CRLF & _
"<ParagraphB>" & @CRLF & _
"<value>34</value>" & @CRLF & _
"<value>56</value>" & @CRLF & _
"<value>75</value>" & @CRLF & _
"</ParagraphB>" & @CRLF & _
"<value>75</value>" & @CRLF & _
"<value>5</value>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")