const regex = /(?:<ParagraphB>|\G<\/value>)\s*?<value>([^<]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<ParagraphB>|\\G<\\\/value>)\\s*?<value>([^<]*)', 'gm')
const str = `<ParagraphA>
<value>12</value>
<value>5</value>
<ParagraphB>
<value>34</value>
<value>56</value>
<value>75</value>
</ParagraphB>
<value>75</value>
<value>5</value>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}