using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<ParagraphB>|\G<\/value>)\s*?<value>([^<]*)";
string input = @"<ParagraphA>
<value>12</value>
<value>5</value>
<ParagraphB>
<value>34</value>
<value>56</value>
<value>75</value>
</ParagraphB>
<value>75</value>
<value>5</value>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}