$re = '/(?:<ParagraphB>|\G<\/value>)\s*?<value>([^<]*)/m';
$str = '<ParagraphA>
<value>12</value>
<value>5</value>
<ParagraphB>
<value>34</value>
<value>56</value>
<value>75</value>
</ParagraphB>
<value>75</value>
<value>5</value>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);