import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<ParagraphB>|\\G<\\/value>)\\s*?<value>([^<]*)";
final String string = "<ParagraphA>\n"
+ "<value>12</value>\n"
+ "<value>5</value>\n"
+ "<ParagraphB>\n"
+ "<value>34</value>\n"
+ "<value>56</value>\n"
+ "<value>75</value>\n"
+ "</ParagraphB>\n"
+ "<value>75</value>\n"
+ "<value>5</value>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}