use strict;
my $str = '<ParagraphA>
<value>12</value>
<value>5</value>
<ParagraphB>
<value>34</value>
<value>56</value>
<value>75</value>
</ParagraphB>
<value>75</value>
<value>5</value>';
my $regex = qr/(?:<ParagraphB>|\G<\/value>)\s*?<value>([^<]*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}