re = /(?:<ParagraphB>|\G<\/value>)\s*?<value>([^<]*)/m
str = '<ParagraphA>
<value>12</value>
<value>5</value>
<ParagraphB>
<value>34</value>
<value>56</value>
<value>75</value>
</ParagraphB>
<value>75</value>
<value>5</value>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end