# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\R+(?=\d{2}:\d{2}:\d{2})/<>/g;t' <<< "bla bla.
14:39:51 info: pyku bla .
14:39:51 info:
14:39:51 info:
14:39:57 Sam: <span>pyk pyk</span>
14:43:15 on and on
14:43:59 you get an idea"