using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\R+(?=\d{2}:\d{2}:\d{2})";
string substitution = @"<>";
string input = @"bla bla.
14:39:51 info: pyku bla .
14:39:51 info:
14:39:51 info:
14:39:57 Sam: <span>pyk pyk</span>
14:43:15 on and on
14:43:59 you get an idea";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}