use strict;
my $str = 'bla bla.
14:39:51 info: pyku bla .
14:39:51 info:
14:39:51 info:
14:39:57 Sam: <span>pyk pyk</span>
14:43:15 on and on
14:43:59 you get an idea';
my $regex = qr/\R+(?=\d{2}:\d{2}:\d{2})/p;
my $subst = '<>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";