import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\R+(?=\\d{2}:\\d{2}:\\d{2})";
final String string = "bla bla.\n"
+ "14:39:51 info: pyku bla .\n"
+ "14:39:51 info: \n"
+ "14:39:51 info: \n"
+ "14:39:57 Sam: <span>pyk pyk</span>\n"
+ "14:43:15 on and on \n"
+ "14:43:59 you get an idea";
final String subst = "<>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}