# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:tree|tall)\b(*SKIP)(*F)|([a-zA-Z])\1+/\1/g;t' <<< "tree tree tall
This tree is veeeeery tall"