use strict;
my $str = 'tree tree tall
This tree is veeeeery tall';
my $regex = qr/\b(?:tree|tall)\b(*SKIP)(*F)|([a-zA-Z])\1+/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";