$re = '/\b(?:tree|tall)\b(*SKIP)(*F)|([a-zA-Z])\1+/';
$str = 'tree tree tall
This tree is veeeeery tall';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;