using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:tree|tall)\b(*SKIP)(*F)|([a-zA-Z])\1+";
string substitution = @"\1";
string input = @"tree tree tall
This tree is veeeeery tall";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}