#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(?:tree|tall)\b(*SKIP)(*F)|([a-zA-Z])\1+"
Local $sString = "tree tree tall " & @CRLF & _
"This tree is veeeeery tall"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)