re = /\b(?:tree|tall)\b(*SKIP)(*F)|([a-zA-Z])\1+/
str = 'tree tree tall
This tree is veeeeery tall'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result