import Foundation
let pattern = #"\b(?:tree|tall)\b(*SKIP)(*F)|([a-zA-Z])\1+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
tree tree tall
This tree is veeeeery tall
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)