import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^a-zA-Z0-9 -._]+";
final String string = "Another one wrapped up this time a 6 bedroom 6 bathroom HMO. More pictures and info to follow. ⠀\n"
+ "⠀\n"
+ "⠀\n"
+ "❗️Support local businesses ❗️⠀\n"
+ "⠀\n"
+ "⠀\n"
+ "@rjhbuildersltd \n"
+ "@lbe_services_ltd \n"
+ "@semtex_mtex ⠀ ⠀\n"
+ "⠀\n"
+ "#plumbing #gassafe #heating #bathroom⠀\n"
+ "#Semtex ⠀\n"
+ "⠀\n"
+ "⠀\n"
+ "#hmo #property #propertyinvestment #buytolet #hermosillo #propertyinvestor #realestate #ukproperty #propertyinvesting #rent #propertydevelopment #landlord #propertydeveloper #propertymanagement #landlords #propertybusiness #business";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}