// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^a-zA-Z0-9 -._]+").unwrap();
let string = "Another one wrapped up this time a 6 bedroom 6 bathroom HMO. More pictures and info to follow. ⠀
⠀
⠀
❗️Support local businesses ❗️⠀
⠀
⠀
@rjhbuildersltd
@lbe_services_ltd
@semtex_mtex ⠀ ⠀
⠀
#plumbing #gassafe #heating #bathroom⠀
#Semtex ⠀
⠀
⠀
#hmo #property #propertyinvestment #buytolet #hermosillo #propertyinvestor #realestate #ukproperty #propertyinvesting #rent #propertydevelopment #landlord #propertydeveloper #propertymanagement #landlords #propertybusiness #business";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}