const regex = /[^a-zA-Z0-9 -._]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z0-9 -._]+', 'gm')
const str = `Another one wrapped up this time a 6 bedroom 6 bathroom HMO. More pictures and info to follow. ⠀
⠀
⠀
❗️Support local businesses ❗️⠀
⠀
⠀
@rjhbuildersltd
@lbe_services_ltd
@semtex_mtex ⠀ ⠀
⠀
#plumbing #gassafe #heating #bathroom⠀
#Semtex ⠀
⠀
⠀
#hmo #property #propertyinvestment #buytolet #hermosillo #propertyinvestor #realestate #ukproperty #propertyinvesting #rent #propertydevelopment #landlord #propertydeveloper #propertymanagement #landlords #propertybusiness #business`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);