use strict;
my $str = 'Another one wrapped up this time a 6 bedroom 6 bathroom HMO. More pictures and info to follow. ⠀
⠀
⠀
❗️Support local businesses ❗️⠀
⠀
⠀
@rjhbuildersltd
@lbe_services_ltd
@semtex_mtex ⠀ ⠀
⠀
#plumbing #gassafe #heating #bathroom⠀
#Semtex ⠀
⠀
⠀
#hmo #property #propertyinvestment #buytolet #hermosillo #propertyinvestor #realestate #ukproperty #propertyinvesting #rent #propertydevelopment #landlord #propertydeveloper #propertymanagement #landlords #propertybusiness #business';
my $regex = qr/[^a-zA-Z0-9 -._]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";