package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z]|[a-z]|\s)+(,\s*(Jr\.|Sr\.|[IV]*))?$`)
var str = ` John Smith, Jr.
Winn Thomas
Mary 3llen Jones
Clyde Franklin, III
wallace firt, the
wimbobimbo ff , VIVIVVVVIIIVIIVVI
s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr.`
var substitution = "Ye Tar Oo Yetaroo3 Uyetar Goffery "
fmt.Println(re.ReplaceAllString(str, substitution))
}