import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z]|[a-z]|\\s)+(,\\s*(Jr\\.|Sr\\.|[IV]*))?$";
final String string = " John Smith, Jr.\n"
+ "Winn Thomas\n"
+ " Mary 3llen Jones \n"
+ "Clyde Franklin, III\n"
+ "wallace firt, the\n"
+ "wimbobimbo ff , VIVIVVVVIIIVIIVVI\n"
+ "s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr.";
final String subst = "Ye Tar Oo Yetaroo3 Uyetar Goffery ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}