# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-[^-]+$//gm;t' <<< "WPa-03
TD-01
RF-08-01
RD-100"