using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-[^-]+$";
string substitution = @"";
string input = @"WPa-03
TD-01
RF-08-01
RD-100";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}