$re = '/-[^-]+$/m';
$str = 'WPa-03
TD-01
RF-08-01
RD-100';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;