package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-[^-]+$`)
var str = `WPa-03
TD-01
RF-08-01
RD-100`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}