const regex = /-[^-]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-[^-]+$', 'gm')
const str = `WPa-03
TD-01
RF-08-01
RD-100`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);