use strict;
my $str = 'WPa-03
TD-01
RF-08-01
RD-100';
my $regex = qr/-[^-]+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";