#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-[^-]+$"
Local $sString = "WPa-03" & @CRLF & _
"TD-01" & @CRLF & _
"RF-08-01" & @CRLF & _
"RD-100"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)