package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(\x{2019})\x{2019}(.+?)\x{2018}(\x{2018})`)
var str = `
I have a document which contains lots of sentences in quotes. Issue is that some of them are properly quoted and some of them have reverse quotes, meaning the opening quotes are at the end of the sentence and closing quotes in the beginning. Like so:
’’المعلقات السبعہ‘‘
‘‘المعلقات السبعہ’’
`
var substitution = "$3$3$2$1$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}