re = /(\x{2019})\x{2019}(.+?)\x{2018}(\x{2018})/
str = '
I have a document which contains lots of sentences in quotes. Issue is that some of them are properly quoted and some of them have reverse quotes, meaning the opening quotes are at the end of the sentence and closing quotes in the beginning. Like so:
’’المعلقات السبعہ‘‘
‘‘المعلقات السبعہ’’
'
subst = '$3$3$2$1$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result