import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\x{2019})\\x{2019}(.+?)\\x{2018}(\\x{2018})";
final String string = "\n\n"
+ "I have a document which contains lots of sentences in quotes. Issue is that some of them are properly quoted and some of them have reverse quotes, meaning the opening quotes are at the end of the sentence and closing quotes in the beginning. Like so:\n"
+ "’’المعلقات السبعہ‘‘\n\n"
+ "‘‘المعلقات السبعہ’’\n\n";
final String subst = "$3$3$2$1$1";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}