// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(\x{2019})\x{2019}(.+?)\x{2018}(\x{2018})").unwrap();
let string = "
I have a document which contains lots of sentences in quotes. Issue is that some of them are properly quoted and some of them have reverse quotes, meaning the opening quotes are at the end of the sentence and closing quotes in the beginning. Like so:
’’المعلقات السبعہ‘‘
‘‘المعلقات السبعہ’’
";
let substitution = "$3$3$2$1$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}