import Foundation
let pattern = #"(\x{2019})\x{2019}(.+?)\x{2018}(\x{2018})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
I have a document which contains lots of sentences in quotes. Issue is that some of them are properly quoted and some of them have reverse quotes, meaning the opening quotes are at the end of the sentence and closing quotes in the beginning. Like so:
’’المعلقات السبعہ‘‘
‘‘المعلقات السبعہ’’
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3$3$2$1$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)