# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\x{2019})\x{2019}(.+?)\x{2018}(\x{2018})"
test_str = ("\n\n"
"I have a document which contains lots of sentences in quotes. Issue is that some of them are properly quoted and some of them have reverse quotes, meaning the opening quotes are at the end of the sentence and closing quotes in the beginning. Like so:\n"
"’’المعلقات السبعہ‘‘\n\n"
"‘‘المعلقات السبعہ’’\n\n")
subst = "$3$3$2$1$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.