const regex = /(\x{2019})\x{2019}(.+?)\x{2018}(\x{2018})/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\x{2019})\\x{2019}(.+?)\\x{2018}(\\x{2018})', 'gs')
const str = `
I have a document which contains lots of sentences in quotes. Issue is that some of them are properly quoted and some of them have reverse quotes, meaning the opening quotes are at the end of the sentence and closing quotes in the beginning. Like so:
’’المعلقات السبعہ‘‘
‘‘المعلقات السبعہ’’
`;
const subst = `$3$3$2$1$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);