# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?<=<[_a-zA-Z][^<]*?))\s+href\s*=\s*["']?\s*javascript:[^"<]*["']?/$1/gm;t' <<< "<a href=\"javascript:console.log(document.cookie)\"></a>
<a href='javascript:console.log(document.cookie)'></a>
<a href = \"javascript:console.log(document.cookie)\"></a>
<a href=\" javascript:console.log(document.cookie)\"></a>
<a href=javascript:console.log(document.cookie)></a>
<a
href=
\"javascript:console.log(document.cookie)\">
</a>"