#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?<=<[_a-zA-Z][^<]*?))\s+href\s*=\s*["']?\s*javascript:[^"<]*["']?"
Local $sString = "<a href="javascript:console.log(document.cookie)"></a>" & @CRLF & _
"<a href='javascript:console.log(document.cookie)'></a>" & @CRLF & _
"<a href = "javascript:console.log(document.cookie)"></a>" & @CRLF & _
"<a href=" javascript:console.log(document.cookie)"></a>" & @CRLF & _
"<a href=javascript:console.log(document.cookie)></a>" & @CRLF & _
"<a " & @CRLF & _
"href=" & @CRLF & _
" "javascript:console.log(document.cookie)">" & @CRLF & _
"</a>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)