use strict;
my $str = '<a href="javascript:console.log(document.cookie)"></a>
<a href=\'javascript:console.log(document.cookie)\'></a>
<a href = "javascript:console.log(document.cookie)"></a>
<a href=" javascript:console.log(document.cookie)"></a>
<a href=javascript:console.log(document.cookie)></a>
<a
href=
"javascript:console.log(document.cookie)">
</a>';
my $regex = qr/((?<=<[_a-zA-Z][^<]*?))\s+href\s*=\s*["']?\s*javascript:[^"<]*["']?/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";