const regex = /((?<=<[_a-zA-Z][^<]*?))\s+href\s*=\s*["']?\s*javascript:[^"<]*["']?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<=<[_a-zA-Z][^<]*?))\\s+href\\s*=\\s*["\']?\\s*javascript:[^"<]*["\']?', 'gm')
const str = `<a href="javascript:console.log(document.cookie)"></a>
<a href='javascript:console.log(document.cookie)'></a>
<a href = "javascript:console.log(document.cookie)"></a>
<a href=" javascript:console.log(document.cookie)"></a>
<a href=javascript:console.log(document.cookie)></a>
<a
href=
"javascript:console.log(document.cookie)">
</a>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);