using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=<[_a-zA-Z][^<]*?))\s+href\s*=\s*[""']?\s*javascript:[^""<]*[""']?";
string substitution = @"$1";
string input = @"<a href=""javascript:console.log(document.cookie)""></a>
<a href='javascript:console.log(document.cookie)'></a>
<a href = ""javascript:console.log(document.cookie)""></a>
<a href="" javascript:console.log(document.cookie)""></a>
<a href=javascript:console.log(document.cookie)></a>
<a
href=
""javascript:console.log(document.cookie)"">
</a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}