re = /((?<=<[_a-zA-Z][^<]*?))\s+href\s*=\s*["']?\s*javascript:[^"<]*["']?/m
str = '<a href="javascript:console.log(document.cookie)"></a>
<a href=\'javascript:console.log(document.cookie)\'></a>
<a href = "javascript:console.log(document.cookie)"></a>
<a href=" javascript:console.log(document.cookie)"></a>
<a href=javascript:console.log(document.cookie)></a>
<a
href=
"javascript:console.log(document.cookie)">
</a>'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result