import re
regex = re.compile(r"((?<=<[_a-zA-Z][^<]*?))\s+href\s*=\s*[\"']?\s*javascript:[^\"<]*[\"']?", flags=re.MULTILINE)
test_str = ("<a href=\"javascript:console.log(document.cookie)\"></a>\n"
"<a href='javascript:console.log(document.cookie)'></a>\n"
"<a href = \"javascript:console.log(document.cookie)\"></a>\n"
"<a href=\" javascript:console.log(document.cookie)\"></a>\n"
"<a href=javascript:console.log(document.cookie)></a>\n"
"<a \n"
"href=\n"
" \"javascript:console.log(document.cookie)\">\n"
"</a>")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)