using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\s)Äpfel(?=$|\s)";
string substitution = @"$1*****";
string input = @"ich mag Äpfel";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}