const regex = /(^|\s)Äpfel(?=$|\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s)Äpfel(?=$|\\s)', 'g')
const str = `ich mag Äpfel`;
const subst = `$1*****`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);