import re
regex = re.compile(r"(^|\s)Äpfel(?=$|\s)")
test_str = "ich mag Äpfel"
subst = "$1*****"
result = regex.sub(subst, test_str)
if result:
print(result)