const regex = /^[^\n\d]*(\d+)(?:[^\n\d]+(\d+))?(?:[^\n\d]+(\d+))?.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\n\\d]*(\\d+)(?:[^\\n\\d]+(\\d+))?(?:[^\\n\\d]+(\\d+))?.*', 'gm')
const str = `T441_S45/1
007_S4
41_445T02_74
`;
const subst = `$1 $2 $3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);