// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\n\d]*(\d+)(?:[^\n\d]+(\d+))?(?:[^\n\d]+(\d+))?.*").unwrap();
let string = "T441_S45/1
007_S4
41_445T02_74
";
let substitution = "$1 $2 $3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}